SWI-Prolog dependencies

SWI-Prolog requires the following packages:

  • libc6 (>= 2.7-1),
  • libgmp3c2,
  • libncurses5 (>= 5.6+20071006-3),
  • libreadline5 (>= 5.2),
  • libgmp3-dev,
  • libreadline5-dev

A clean install

To install the required packages manually (i.e., when compiling swipl from scratch or using a converted RPM package), do the following:

sudo apt-get install libc6 libgmp3c2 libncurses5 libreadline5 libgmp3-dev libreadline5-dev

A quick fix

Another way to install the required packages is to install the swi-prolog package itself (available in Ubuntu universe repository, unavailable in Etch stable) and then remove it:

sudo apt-get install swi-prolog
...
sudo apt-get remove swi-prolog
pl/prolog/jpl/dependencies.txt · ostatnio zmienione: 2017/07/17 08:08 (edycja zewnętrzna)
www.chimeric.de Valid CSS Driven by DokuWiki do yourself a favour and use a real browser - get firefox!! Recent changes RSS feed Valid XHTML 1.0